Solaris Package
Solaris Package Manager
– pkginfo -l (Anzeige der installierten Packages)
– pkgchk -v
– pkgadd -R -d (Package installieren)
– pkgrm
RedHat Package Manager
rpm -qi | get info |
rpm -ivh | install a package |
rpm -Uvh rpm -e | upgrade a package |
rpm -ql | which files belong to a package |
rpm -qilp | look in a rpm filename that isnt installed |
will give you a list of all files that have changed in one form or another since the package it is associated was installed. $ rpm -Va | awk ”{print $2}” | xargs rpm -qf | sort -u &> /tmp/file1 |
the way to compile a package:
gunzip < file.tar.gz | tar xvf –
./configure to configure the package
make to compile the package.
make check to run any self-tests
make install to install the programs
make clean to remove the program binaries
Leave a Reply